Проблема с оформлением заказа

Правила раздела: faq.php?mode=okay
Модератор: Модераторы

evgennova
evgennova
Репутация: 13
Сообщения: 200
Зарегистрирован: 17.02.2021
С нами: 1 год 4 месяца

Сообщение #1 evgennova » 03.07.2021, 19:33

Версия 4.1.1
Проблема обнаружена в секторе настройка сайта - настройка уведомлений - Настройки SMTP.
При включенной отправке почты и заполнении всех параметров для работы через smtp.

Если вдруг, на сервере, по каким-то причинам есть проблема в работе smtp сервера (отправка почты) - будут возникать проблемы на сайте:

При оформлении заказа - внесения всех данных и подтверждения - есть проблема с обработкой страницы:
Для клиента - страница оформления заказа зависает намертво на неопределенный период (как и сам сайт)
Для продавца - заказ приходит через какое-то время

p.s. проблема с конектом может возникать по другой причине:
при "Проверка соединения с SMTP сервером" и введенных данных Настройки SMTP - выдает сообщение "Connect OK", но при сохранении этих параметров и новой проверке - система уже выдает ошибку "Connect failed"
Версия 4.1.1 :smoke:

Dysha-Kuzbass M
Аватара
Dysha-Kuzbass M
Возраст: 35
Репутация: 3
Сообщения: 157
Зарегистрирован: 17.05.2017
С нами: 5 лет 1 месяц
Откуда: Кузбасс
ВКонтакте

Сообщение #2 Dysha-Kuzbass » 07.07.2021, 00:22

А с хостингом не наблюдалось проблем?

evgennova
evgennova
Репутация: 13
Сообщения: 200
Зарегистрирован: 17.02.2021
С нами: 1 год 4 месяца

Сообщение #3 evgennova » 07.07.2021, 06:31

Dysha-Kuzbass писал(а):А с хостингом не наблюдалось проблем?
хостинг несколько раз перезагружал, модуль exim отдельно тоже перезагружался.
почта ходит с теми же данными.

проблема обнаружилась на cms:
1. при внесении новых данных и проверки на валидность отправки почты через smtp - "ок"
2. если потом это все сохранить - при проверке уже будет ошибка - и почта не будет приходить....
3. если внести все данные для smtp и сразу сохранить без проверок - все работает как часы

p.s. в лагах явно читается что ошибка возникает при проверке логина и пароля на почтовые ящик (если сделать 1-2) - работать не будет, если только п.3 - все работает. при всем при этом логин и пароль к ящику валидный и на сервере ошибок при проверке нет....

как можно исправить (если у кого была подобная ошибка):
1. ввести данные другого ящика и сохранить без проверок
2. вернуть обратно данные нужного ящика и сохранить без проверок
Версия 4.1.1 :smoke:


Название раздела: Баг-репорт OkayCMS (Сообщения об ошибках)
Правила раздела: faq.php?mode=okay

Быстрый ответ


Введите код в точности так, как вы его видите. Регистр символов не имеет значения.
Код подтверждения

   

Вернуться в «Баг-репорт OkayCMS (Сообщения об ошибках)»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 4 гостя