Ошибка соединения 1С в 4.3.0 (файл Design.php)

Правила раздела: faq.php?mode=okay
Модератор: Модераторы

Vell M
Vell M
Возраст: 37
Репутация: 1
Сообщения: 7
Зарегистрирован: 29.01.2022
С нами: 6 месяцев 16 дней
Откуда: Турция

Сообщение #1 Vell » 15.04.2022, 16:44

Здравствуйте!
В версии 4.3.0 при выгрузке товаров из 1С ошибка сервера 500 (пустой ответ). Проверил на двух своих сайтах + demookay.
При прямом обращении по адресу домен/cml/1c_exchange.php аналогично. В предыдущей версии при этом стабильный запрос на авторизацию.
Поиски привели к файлу Okay/Core/Design.php.
Пока глубоко не разбирался из-за отсутствия времени. Заменил его на файл из предыдущей версии Okay - ошибка ушла, соединение устанавливается стабильно, но прошу обратить внимание.

OkayCMS M
Администратор
Аватара
OkayCMS M
Администратор
Репутация: 210
Сообщения: 1604
Зарегистрирован: 12.11.2015
С нами: 6 лет 9 месяцев
Сайт Skype

Сообщение #2 OkayCMS » 16.04.2022, 16:18

Да, фикс уже есть на гитхабе, в 4.3.1 поправим

Thud12
Thud12
Репутация: 0
Сообщения: 1
Зарегистрирован: 20.04.2022
С нами: 3 месяца 24 дня

Сообщение #3 Thud12 » 20.04.2022, 15:35

OkayCMS писал(а):Да, фикс уже есть на гитхабе, в 4.3.1 поправим
А можно ссылку на фикс, спасибо!

korvin
Аватара
korvin
Репутация: 0
Сообщения: 11
Зарегистрирован: 02.04.2022
С нами: 4 месяца 12 дней

Сообщение #4 korvin » 21.04.2022, 10:02



Название раздела: Баг-репорт OkayCMS (Сообщения об ошибках)
Правила раздела: faq.php?mode=okay

Быстрый ответ


Введите код в точности так, как вы его видите. Регистр символов не имеет значения.
Код подтверждения

   

Вернуться в «Баг-репорт OkayCMS (Сообщения об ошибках)»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 4 гостя