v2.3.4 присутствует ошибка в отображении Мета-тегов, H1, Title на страницах /all-products/page-*

Правила раздела: faq.php?mode=okay
Модератор: Модераторы

IvanIvanov
IvanIvanov
Репутация: 0
Сообщения: 9
Зарегистрирован: 12.09.2019
С нами: 1 месяц 9 дней

Сообщение #1 IvanIvanov » 26.09.2019, 18:30

На странице всех товаров /all-products/page-2, /all-products/page-3 и далее, а также /all-products/page-all не отображаются мета-теги, H1, Title.
Подскажите как решить данный вопрос.
Последний раз редактировалось IvanIvanov 17.10.2019, 09:59, всего редактировалось 4 раза.

n4sm
n4sm
Репутация: 2
Сообщения: 12
Зарегистрирован: 27.02.2019
С нами: 7 месяцев 23 дня

Сообщение #2 n4sm » 27.09.2019, 08:00

IvanIvanov писал(а):Подскажите как решить данный вопрос.
Пардон, а зачем индексировать эти страницы?
Там не просто так стоит: <meta name="robots" content="noindex,follow">
Это не баг, а фича :D
/all-products/page-all - вообще страшная страница, на которую лучше никогда не заходить.

IvanIvanov
IvanIvanov
Репутация: 0
Сообщения: 9
Зарегистрирован: 12.09.2019
С нами: 1 месяц 9 дней

Сообщение #3 IvanIvanov » 27.09.2019, 08:38

Ну, в принципе, индексировать конечно и не зачем!
Тут, скажем, задача отображения в H1, Title!
Если в products.tpl вместо {include file='chpu_pagination.tpl'} сделать {include file='pagination.tpl'}, то всё в порядке. А при обратном раскладе - не так уж всё радужно!

IvanIvanov
IvanIvanov
Репутация: 0
Сообщения: 9
Зарегистрирован: 12.09.2019
С нами: 1 месяц 9 дней

Сообщение #4 IvanIvanov » 17.10.2019, 09:58

Как всё-таки можно реализовать это? Кто-нибудь подскажет решение?!...


Название раздела: Вопросы по работе с OkayCMS
Правила раздела: faq.php?mode=okay

Быстрый ответ


Введите код в точности так, как вы его видите. Регистр символов не имеет значения.
Код подтверждения

   

Вернуться в «Вопросы по работе с OkayCMS»

Кто сейчас на форуме (по активности за 5 минут)

Сейчас этот раздел просматривают: 1 гость